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Preface
ADVANCED Motion Controls constantly strives to improve all of its products. We review the information in 
this document regularly and we welcome any suggestions for improvement. We reserve the right to modify 
equipment and documentation without prior notice.

For the latest revision of this document, visit the company’s website at www.a-m-c.com. Otherwise, contact 
the company directly at:

ADVANCED Motion Controls • 3805 Calle Tecate Camarillo, CA • 93012-5068 USA

This manual is for the exclusive use of ADVANCED Motion Controls. The reproduction, transmission or 
use of this document or its contents is prohibited without the expressed written permission of ADVANCED 
Motion Controls.

General Safety

You must install and operate ADVANCED Motion Controls motion control equipment so that 
you meet all applicable safety requirements. Ensure that you identify the relevant standards 
and comply with them. Failure to do so may result in damage to equipment and personal 
injury.

Read this entire manual prior to attempting to install or operate the drive. Become familiar 
with practices and procedures that allow you to operate these drives safely and effectively. 
You are responsible for determining the suitability of this product for the intended 
application. ADVANCED Motion Controls is neither responsible nor liable for indirect or 
consequential damages resulting from the inappropriate use of this product.

High-performance motion control equipment can move rapidly with very high forces. 
Unexpected motion may occur especially during product commissioning. Keep clear of any 
operational machinery and never touch them while they are working.
MNDGCMQR-02 ii

http://www.a-m-c.com


 / 
Keep clear of enclosed units, motor terminals, and transformer terminals when power is 
applied to the equipment. Follow these safety guidelines:

• Always turn off the main power and allow sufficient time for complete discharge before 
making any connections to the drive.

• Make sure that the minimum inductance requirements are met. Pulse Width 
Modulated (PWM) amplifiers deliver a pulsed output that requires a minimum amount 
of load inductance for proper operation.

• Do not rotate the motor shaft without power. The motor acts as a generator and will 
charge up the power supply capacitors through the amplifier. Excessive speeds may 
cause over-voltage breakdown in the power output stage. Note that an amplifier 
having an internal power converter that operates from the high voltage supply will 
become operative.

• Do not short the motor leads at high motor speeds. When the motor is shorted, its own 
generated voltage may produce a current flow as high as 10 times the amplifier 
current. The short itself may not damage the amplifier but may damage the motor.

• Do not make any connections to any internal circuitry. Only connections to designated 
connectors are allowed.

ADVANCED Motion Controls, the combined isosceles trapezoid/right triangle logo, DIGIFLEX®, 
DIGIFLEX® Performance, Click&Move®, and DriveWare® are either registered trademarks or 
trademarks of ADVANCED Motion Controls in the United States and/or other countries. All other 
trademarks are the property of their respective owners.

Related Documentation

• Product datasheet specific for your drive, available for download at www.a-m-c.com

© 2016 ADVANCED Motion Controls. All rights reserved.
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Click&Move® Automation Solution

Click&Move® (C&M) is an Automation Solution. It is designed to be an application solution for OEMs, systems integrators, and end users. C&M can include motion control, PLC logic, local I/O, and networked I/O. Applications can be simple, single-axis with minimal I/O, to complex, multi-axes running in real-time.
Click&Move Automation Solution   

• Combines Motion, PLC, and HMI control
• Based on PLCopen, the global standard for industrial control programming
• Fully IEC 61131-3 compliant using graphical Function Block Diagrams (FBDs)
• Multiple platforms supported: PC (Win OS and Linux), Stand-alone controller (MACC), and 

ADVANCED Motion Controls®’ servo drives

• Supports CANopen and EtherCAT® network protocols
Click&Move Integrated Development Environment (IDE)   The C&M IDE provides the user with a programming environment for a range of applications: Motion, PLC machine control, G-code file handling for CNC applications, Process control, and Robotics. The IDE consists of applications to graphically create/edit FBD-based logic schematics and HMI screens, debug application code, organize and archive application code, merge and compare code as well as automating the build/compile steps.This document presents a step-by-step walkthrough in how to create a simple two-axis virtual project, and then to convert it to work with real motors.
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Install Click&MoveTo install Click&Move on a PC, follow these simple steps.
1. Download the software from www.a-m-c.com/products/clickandmove.html.
2. Run CandM-5.3.3.exe. Follow the onscreen instructions to complete the installation.
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Step 1 - New Two Axis ProjectStart Click&Move by using the Run shortcut from the start menu.
 

Close the currently open project (File > Close project), then select:
File > New Project > Two Axes with CANopen Network.
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Step 2 - Name the Project

In the dialog window that appears, change the project Parent directory to the 
...\CandM\Working_5_3_3\Projects directory.

Give the project a name and click OK.C&M automatically builds a two-axis skeleton project. The project contains 3 function blocks.Select the Open Schematic icon from the C&M Desktop to see a list of schematics in the project.

• C_M_MAIN.sch
• TWO_CAN_AXIS_SET_UP.sch
• AXIS_SET_UP.schClose the Open Schematic window for now.
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Step 3 - View HMI and Project DescriptionClick&Move creates a simple HMI with a new project. Click the Run C&M-HMI icon from the C&M Desktop to open the HMI.

The HMI has controls to run the project, set a target position, and start the move to the target position. The View Error button provides a way to view error status. The Reset button provides a way to reset error conditions.

Close the HMI for now.Click the Project Description icon from the C&M Desktop to open the project description file. This file is used to described the project and provide help to the operator.

Close the project file.
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Step 4 - Build and Test New Project in Virtual ModeSelect the Rebuild icon from the C&M Desktop to build the project. Do not interrupt Click&Move while the build is in progress.

Upon completion, the message "Project is successfully built" is displayed at the bottom of the Message Window. After the build completes, click the Run All icon from the C&M Desktop to launch all components of the project at the same time.

Click the Power button  in the Graphical HMI to start the application and establish CAN communication to the virtual axes.Enter a target position into the Target Position field , and then click the Start button . The pointers on the virtual axes will spin to represent motion and stop when the 
Actual Position matches the Target Position.
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Step 5 - Click&Move Runtime Parts The project that has been created works with virtual axes which represent real hardware. Each virtual axis is an independent executable program. The HMI is another executable program and can be ran independently from the other programs.Select Project > Options from the C&M Desktop, and choose the Desktop options tab.

This window controls the programs launched when you click the run button.The Desktop options tab contains a field that allows the user to swap between the graphical HMI and the Mini-HMI. The Mini-HMI automatically displays controls for each input and output of the project.

Un-check the C&M HMI box, and check the C&M-Min-HMI box. Click Apply, and then OK.
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Step 6 - Using Mini-HMI

 Open the main schematic of the project (C_M_MAIN.sch) using the Open Schematic icon , or 
File > Open FGD (Schematic). Locate the INTERFACE object. Right-click the INTERFACE object and choose C&M Set/Connect.

Clear the TYPE = field. With no type defined, the Mini-HMI will be free to communicate with the project IOs.Click OK, save the project (File > 
Save Project As...), and close the schematic.

Rebuild the project by clicking the Rebuild icon  and click the Run-All icon . The C&M Min-HMI will now open as the default control interface.

Multiple HMI’s can read project outputs, but only one HMI may talk to 
project inputs. If you have problems using an HMI, check the INTERFACE 
object.

Note
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Step 7 - Collected ApplicationThe separate parts of the project can be combined into a collected application. The collected application build time files cannot be changed, but it can be run without opening it under C&M.On the C&M Desktop, click Collected C&M Application < Create.

Select the Target Name as "PCW-PC with Microsoft Windows", and click OK.

Enter "TwoAxisCollectedVirtual" into the Application Name field, and click OK.
MNDGCMQR-02 9



Step 8 - Add Projects to the CollectionClick the Add project button in the Collected Application window, and the Add project to 
Application window will appear.

Click the browse button to change the Project parent directory to 
...\C&M\Working_5_3_3\Projects.Under Project name, use the drop-down menu to select "YourProjectName(MGW-PCW)". Click 
OK.

Repeat the steps above to also add the project "CandM_MIN-HMI(ALL-PCW)".
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Step 9 - Add Virtual DrivesClick the Add virtual device button in the Collected Application window.

In the Add virtual device to Application window that appears, select "VirtualDriveDPCxxxx(ALL-PCW)" and then click OK.

Repeat the above steps to add a second instance of "VirtualDriveDPCxxxx(ALL-PCW)". These are the virtual CAN drives.
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Step 10 - Complete and Run the CollectionClick the OK button in the Collected Application window to complete the collected application.

On the C&M Desktop, select Collected C&M Application > Run.Select the collected application that was just created and click OK. The entire program will load and run.
MNDGCMQR-02 12



Step 11 - Package for ReleaseThe Collected Application can be packaged for released. When released, the C&M Desktop is no longer needed to launch the application.From the C&M Desktop, select File > Package collected application for release.

Select "PCW - PC with Microsoft Windows" and click OK.Locate the collected application and select it in the Select collected application for release 
window. Click OK.In the Select package name and directory for release window, click OK to use the same name as previously chosen for the released program.

The message "Packing collected application OK" will appear in the message window.
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Step 12 - Run Packaged ApplicationNavigate in Windows Explorer to find the released application in the ...\PackagedCollectedApplications directory.

Two batch files are provided to launch and terminate the application. The C&M Desktop can be closed, as it is not needed to run a released application.
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Step 13 - Convert the Project to Real AxesThe rest of the procedure outlined in this document describes how to convert the two axis virtual motion project to work with real motors.
Note: It is not necessary to use actual hardware to complete the following steps in this 
document. The procedure can be followed as a simulated exercise to learn some of the basic features and functions of Click&Move without connecting to actual servo drives or motors. However, if actual drive hardware is to be included, the following requirements must be met before proceeding:
 2 ADVANCED Motion Controls’ CAN capable servo drives, commissioned and tuned, connected to PC
 CAN hardware/software on PCOnce the preceding requirements have been met (or if simulating the exercise on software only), begin the procedure as follows:
1. Close the HMI window and the two virtual axes windows. Click the Close C&M Application button  to stop the application.
2. Select Project > Options from the C&M Desktop, and select the Desktop options tab.
3. Uncheck the C&M-Min-HMI box, and check the C&M-HMI box to return to using the graphical HMI as the default.
4. Uncheck the Virtual machine checkbox.

5. Click Apply, then click OK.
6. Click the Open Schematic icon  from the C&M Desktop, and open C_M_MAIN.sch.
7. Right-click on the INTERFACE object, and select C&M Set/Connect.
8. Click the CM_HMI* button in the TYPE = field to assign the interface to the graphical HMI.
9. Click OK.
10. Close the schematic and save changes when prompted.
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Step 14 - Open XML EditorSelect Project > Open XML property file editor from the C&M Desktop.

Click the Open File icon  in the XML Editor window to open the Open XML file window.

The Open XML file window contains three panes. The right pane lists files automatically generated by C&M. Files in the right pane are overwritten each time the project is rebuilt. The middle pane lists XML files manually configured for the project. In this procedure, three configuration files must be moved from the right pane to the middle pane. To move a file, select it and use the arrow button .

Move "Ccom1.prop.xml (PCW)", "Ax1.prop.xml", and "Ax2.prop.xml" from the right pane to the middle pane.
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Step 15 - Set up CAN ConfigurationOpen "Ccom1.prop.xml (PCW)" by double-clicking on it in the center pane. From the XML 
Editor window, select InitialData from the left panel.

Configure the attribute values as follows:

Click the Close File icon  in the XML Editor toolbar and save the changes.

Attribute Name Attribute Value

AdaptorName CANAdaptorKvaser

CardId PCIcan #0 (Channel 0)

Port 0

Baudrate 1000

SendTimeoutMessage 1

These values are valid using a computer with PCI CAN installed. 
Selections may differ due to installed hardware.

Note
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Step 16 - Configure Axis 1 XML Attributes

Click the Open File icon  from the XML Editor toolbar. Open "Ax1.prop.xml" to open the Axis 1 property XML file, then click on InitialData in the left panel.

Change the attribute values listed here as follows (note that the values used will depend on the actual hardware in use):

Click the Close File icon  in the XML Editor toolbar and save the changes.

Attribute Name Attribute Value

NodeId 1

MovementType Linear

PositionTechnicalUnitNumer 1

PositionTechnicalUnitDenom 8000

HandwheelModeEnabled NO

Position Technical Units Numerator is 1mm linear travel for one revolution 
of the motor. Position Technical Units Denominator is 8000 encoder 
counts per revolution of the motor.

Note
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Step 17 - Configure Axis 2 XML Attributes

Click the Open File icon  from the XML Editor toolbar. Open "Ax2.prop.xml" to open the Axis 2 property XML file, then click on InitialData.

Change the attribute values listed here as follows (note that the values used will depend on the actual hardware in use):

Click the Close File icon  in the XML Editor toolbar and save the changes.

Attribute Name Attribute Value

NodeId 2

MovementType Linear

PositionTechnicalUnitNumer 1

PositionTechnicalUnitDenom 8000

HandwheelModeEnabled NO

Position Technical Units Numerator is 1mm linear travel for one revolution 
of the motor. Position Technical Units Denominator is 8000 encoder 
counts per revolution of the motor.

Note
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Step 18 - Test the Project Using Real Axes

Rebuild the project using the Rebuild icon  on the C&M Desktop.

Click the Run All icon  from the C&M Desktop to launch all components of the project at the same time. Upon starting the project, CAN communication is established with the drives. Wait for the flashing text under the Reset button. Once communication is established, we can power up the drives.Click the Power button  to power up the drives and bring them to the ready standby condition. Enter a target position into the Target Position field  and click the Start button . The motors will spin and stop when the Actual Position matches the Target Position.

If simulating the exercise on software only with no drives or hardware 
connected, errors may occur during the build procedure. Click OK in any 
error windows and the build will continue automatically. 

Note
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Step 19 - Add Controls to the ProjectThis step will add controls to set the position and velocity of each axis.Click the Open Schematic icon  and select the main project schematic (C_M_MAIN.sch). Click the Add Library Element icon  from the schematic toolbar and select INPUT from the list of Basic Elements.

Click the OK button to begin adding inputs to the schematic.
DO NOT click the Drop button! It will remove the selected item from the 
library!
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Add Controls to the Project (continued)Schematic elements are added by clicking the mouse on the schematic. Add 3 inputs to the top center of the drawing as shown below (IN5, IN6, IN7).

Repeat the process to add an output to the schematic as well: click the Add Library Element icon  from the schematic toolbar and select OUTPUT from the list of Basic Elements. Place the output on the schematic as shown below (OUT7).

Press the ESCAPE key on the keyboard twice to exit Add Mode.
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Add Controls to the Project (continued)To make room for the new connections, set the editor to Move Mode with the Move icon . The Move icon allows one object to moved at a time by left-clicking on the desired object and dragging it to a new location. To move multiple objects, click the Group icon  and draw a rectangle around the group of objects.Right click to display options and select "Move Group". The group will follow the mouse pointer, and can be placed by clicking the left mouse button.Move the MC1 and MC2 blocks to the right by using the Group icon as shown below.
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Add Controls to the Project (continued)Click on the Delete icon  from the schematic toolbar to put the schematic editor in delete mode.Delete the connection to POSITION on MC2.

Click on the Add Connection icon  and connect the inputs added earlier to the velocity, position and acceleration inputs of the MC1 and MC2 blocks as shown below, and connect the output to the Axis 2 Actual Position. Using a left click will start the line, and additional left clicks will anchor corners. Clicking on the end of a pin to make the connection will complete the line.
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Add Controls to the Project (continued)Click on the Information icon  on the schematic toolbar to display information about selected objects. Click on one of the added inputs and set the name to match the connector to the motion blocks as shown below. Repeat for the other two added inputs, and the added output

Enter the names in the Value field for each element. Rename the original POSITION input to AXIS1_POSITION. 

Close the schematic and save the changes.

Do not use spaces in the Value field. Use upper-case letters and 
underscores to separate the words.

Note
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Step 20 - Rebuild and Run Graphical HMI

Click on the Build Changes icon  on the C&M Desktop. The Build Changes feature saves time by building only the changes made to the project.

After the build completes, select the Run C&M HMI icon  on the C&M Desktop to load and run the HMI. Expand the HMI to fullscreen. Function shortcut keys can toggle certain display features if they are missing:

Function Key Display Feature(s)

F2 Menu Bar and Toolbar

F11 Project Manager

F12 System Messages Window and C&M Version Info
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Step 21 - Edit HMI Controls

Click the Edit Component icon  from the HMI toolbar to put the HMI into edit mode.The screen should appear similar as shown below with the HMI editing sidebars now open.

HMI Editing Controls   To add a control to the HMI, click and hold on the object, drag it to the desired location, and release the mouse button. The object can be moved later by clicking-and-dragging to the new location.To change the size of an object, first select it by left-clicking, then right-click to display the size controls.To select multiple objects in the HMI workspace, click-and-drag a rectangle around the desired objects. When the mouse button is released, the controls will be highlighted.
The keyboard arrows can be used to make fine adjustments to selected 
objects or groups of objects.

Note
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Edit HMI Controls (continued)Begin by moving the compile image warning down to make room for some new controls.

Drag a rectangle around the position controls to select multiple objects.

Select Edit > Duplicate from the HMI editing tools menu bar.

The highlighted controls will be duplicated and added to the HMI. Click-and-drag the new controls to a new location.
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Edit HMI Controls (continued)Click on the control box for the first Target Position to display the properties in the lower left side of the HMI workspace.
Locate the ’Prompt’ entry, and click on the value field. Highlight the text portion (not the space between the single quotes).

Change the text to read "Axis 1 Target Position", and then press Enter. The control display will update to the new value.

The spaces between the single quotes in the ’Prompt’ entry set the size of 
the control’s display area.

Note
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Edit HMI Controls (continued)The next step is to connect the HMI control to the input that was created earlier on the schematic (AXIS1_POSITION). Locate the ’Variable’ entry in the property window, and click the selection icon  next to it to open the Variable list and select window.

Click on the line with M.AXIS1_POSITION and click Apply. The property window will show the new variable selection.Repeat the preceding steps for the second Target Position control properties, mapping it to the AXIS2 values:
1. Click on the control box for the second Target Position control, change the ’Prompt’ entry to "Axis 2 Target Position".
2. Assign the ’Variable’ entry to M.AXIS2_POSITION.

The ’M’ prefix for variable names identifies variables that originate from 
the motion side of the project.

Note
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Edit HMI Controls (continued)Change the text for the first Actual Position control by selecting the text of the Actual Position control (not the numerical field), and changing the text in the ’Caption’ property entry to read "Axis 1 Actual Position".

Next, select the numerical field of Axis 1 Actual Position on the HMI, and click on the selection icon  next to the ’Variable’ entry to assign it to M.AXIS1_ACT_POS.

Repeat the preceding steps for the second Actual Position control properties, mapping it to the AXIS2_ACT_POS values:
1. Click on the text box for the second Actual Position control, change the ’Caption’ entry to "Axis 2 Actual Position".
2. Assign the ’Variable’ entry of the numerical field to M.AXIS2_ACT_POS.
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Edit HMI Controls (continued)Add two more HMI input controls for Velocity and Acceleration by using the Edit > Duplicate command, then changing the ’Prompt’ and ’Variable’ properties for each respective input control to match the Velocity and Acceleration input mappings.

To exit the HMI edit mode, click the Edit Component icon  in the HMI toolbar and save when prompted. You can also use the keyboard shortcut CTRL+ALT+E to toggle edit mode.Test the project by entering target position, velocity, and acceleration values in the HMI controls.
Depending on the motor or servo drive configuration of the hardware in 
use, there may be errors generated if physical limits are exceeded.
MNDGCMQR-02 32



Click&Move® Startup Guide 
MNDGCMQR-02

3805 Calle Tecate • Camarillo, CA 93012-5068
Tel: (805) 389-1935 Fax: (805) 384-2315 www.a-m-c.com


	Preface
	Click&Move® Automation Solution
	Step 1 - New Two Axis Project
	Step 2 - Name the Project
	Step 3 - View HMI and Project Description
	Step 4 - Build and Test New Project in Virtual Mode
	Step 5 - Click&Move Runtime Parts
	Step 6 - Using Mini-HMI
	Step 7 - Collected Application
	Step 8 - Add Projects to the Collection
	Step 9 - Add Virtual Drives
	Step 10 - Complete and Run the Collection
	Step 11 - Package for Release
	Step 12 - Run Packaged Application
	Step 13 - Convert the Project to Real Axes
	Step 14 - Open XML Editor
	Step 15 - Set up CAN Configuration
	Step 16 - Configure Axis 1 XML Attributes
	Step 17 - Configure Axis 2 XML Attributes
	Step 18 - Test the Project Using Real Axes
	Step 19 - Add Controls to the Project
	Step 20 - Rebuild and Run Graphical HMI
	Step 21 - Edit HMI Controls

